New to Forum, & life with a Norton. (commando 2018 - 961 Cafe)

Joined
Jan 16, 2015
Messages
3,894
Country flag
What kind of issues were the OEM relays causing? My only issue was one vibrated loose on a ride. Shut the bike down while rolling at about 110mph. Took me longer to get the seat off than to diagnose the problem.
I have not had a failure with the OEM relays . Others have and they can chime in also. There was a headlamp failure and I don't remember what failure Trevor had with his relay. The only definite problem is you can't get the Norton relays now . Which one vibrated loose ? With the foam in the fuse box and a ty-rap around the grey cover and they still came out ?
 
Joined
May 2, 2021
Messages
13
Country flag
I can’t remember where I read this, but the topic was around TPS reset procedure.

If I recall correctly it goes like this:

1. Switch on ign, do not start engine.
2. turn the twistgrip all the way from closed, to WOT, and closed again.
3. switch off ign
4. switch on ign and start the engine as normal.

Doesn’t cost owt or harm owt... might be worth a try ?
Thanks FE, just tried it, didn't want to know! no change unfortunately.
 
Joined
May 2, 2021
Messages
13
Country flag
Welcome to the forum and the 961 world P-Roger. You have come to the right place for advise and insight. I'm convinced that some of these guys know more about the 961 than Norton. The suggested ignition and sensor upgrade is a great step in the right direction.
Thanks, I've ordered some sensors, and coil as well. i haven't ordered any O2 sensors as i still don't have a part reference number for the Bosh or Honeywell equivalent? unless somebody knows?
I've replaced the spark plugs, the ones i took out that have been in the bike from new (200ks) were black?
 
Joined
May 2, 2021
Messages
13
Country flag
Welcome to the forum and the 961 world P-Roger. You have come to the right place for advise and insight. I'm convinced that some of these guys know more about the 961 than Norton. The suggested ignition and sensor upgrade is a great step in the right direction.
Ignition censor ? any recommendations?
 
Joined
May 2, 2021
Messages
13
Country flag
I hope your cable and software works .... What was it like when you have it a handful of throttle when the engine was under load. Also were your plugs black and sooty like mine?
thanks, replaced the plugs yesterday with the iridium, correct the plugs i replaced were black and were in the bike from new (200k's)
 

cliffa

VIP MEMBER
Joined
May 26, 2013
Messages
2,018
Country flag
I have not had a failure with the OEM relays . Others have and they can chime in also. There was a headlamp failure and I don't remember what failure Trevor had with his relay. The only definite problem is you can't get the Norton relays now . Which one vibrated loose ? With the foam in the fuse box and a ty-rap around the grey cover and they still came out ?
If the original relays are all the same as fitted to mine, they have a resistor in parallel with the coil so fitting a relay with a diode in parallel instead will make it polarity conscious, which probably explains Clive's headlight outage and the need to reverse the connectors.
 

Vernon240

VIP MEMBER
Joined
Mar 18, 2021
Messages
163
Country flag
The pickup at the crankshaft rotor ?
I think there is some mixing up of terms. Ignition and sensor upgrades was the recommendation.

P-Rogers, there is quite a lot about these, but here's what you need to look at:

Ignition:
Ignition coil pack
Ignition HT leads
Spark Plugs

Sensors:
Crank sensor.
Engine temp sensor.

Genaral:
6x relays
 
Joined
Jan 5, 2014
Messages
2,650
Country flag
What kind of issues were the OEM relays causing? My only issue was one vibrated loose on a ride. Shut the bike down while rolling at about 110mph. Took me longer to get the seat off than to diagnose the problem.
Happened to me once. Didn't have a 5MM hex with me. That was after treating it to dielectric grease. I never had a relay problem but swapped them for the hell of it. Tony gives good advice.
 
Joined
Sep 26, 2017
Messages
203
Country flag
I have not had a failure with the OEM relays . Others have and they can chime in also. There was a headlamp failure and I don't remember what failure Trevor had with his relay. The only definite problem is you can't get the Norton relays now . Which one vibrated loose ? With the foam in the fuse box and a ty-rap around the grey cover and they still came out ?
The relay didn't come completely out. Just enough to break the connection and kill the ignition. I'll have to look to see it there is foam in the grey cover. There will be if there isn't. Seems to be a debate over what's best to replace them with.
 

Clive

VIP MEMBER
Joined
Jun 9, 2017
Messages
751
Country flag
The relay didn't come completely out. Just enough to break the connection and kill the ignition. I'll have to look to see it there is foam in the grey cover. There will be if there isn't. Seems to be a debate over what's best to replace them with.
Absolutely anything that costs more than $0.20 and is not sent direct from China! Just watch that diode issue - it should actually make for a more reliable relay once you get the wire polarity right. I had the headlight and ignition relays both fail.
 
Top