New Owner in Dallas

Joined
Oct 24, 2015
Messages
50
Hello Everyone, just wanted to say howdy from Dallas. Just picked a VERY low mileage 2014 CR on Tuesday.

First impression is that of what all owners are saying and I've been reading about. First of all, im biased and going to give all kinds of benefit of doubts until my bike is broken in and dialed in.

Put about 50 miles in 1.5 days just learning and feeling out the bike. Already have shortie pipes from KH. I'm going to wait til my first service to put them on and remapped.

Will keep y'all posted.

By the way, how do I upload pic/video?
 
Joined
Nov 29, 2013
Messages
798
Country flag
Congrats, there are vids on YouTube showing how to post photos, its easy once you do a couple. Get that pipe on asap, it will be a different bike.
 
Joined
Oct 24, 2015
Messages
50
After riding 100 miles last two days (before the rain moved in) I have to say my confidence is not very high. Like I said, I'm going to wait for the bike to be broken in (500 miles) to make comments but sure doesn't give me the impression of riding a hand built updated high quality motorcycle. It feels like I'm riding a bike that has too many loose nuts...clanking all kinds of noise. It really feels like I'm riding a vintage. :wink:
 
Joined
Jan 16, 2015
Messages
3,250
Country flag
Hello DallasNorton , You must have read about the clacky primary drive right ? Also , there is some vibration not real bad but its there. This smooths out and is somewhat comfortable when cruising at highway speeds. Are you still having those rough running issues ? You may have a loose connection on one of the sensors. Have you been in the rain ? Check the air flow sensor at the top of the airbox and spray some silicone to drive out moisture after you blow it out with compressed air. Frankly , This whining is getting old . I get this from my kids.
 
Joined
Nov 29, 2013
Messages
798
Country flag
Dallas, that Is why you need to put the shorty on now, that and mileage will improve the sounds, but mostly the pipe.
 
Joined
Oct 24, 2015
Messages
50
TonyA said:
Hello DallasNorton , You must have read about the clacky primary drive right ? Also , there is some vibration not real bad but its there. This smooths out and is somewhat comfortable when cruising at highway speeds. Are you still having those rough running issues ? You may have a loose connection on one of the sensors. Have you been in the rain ? Check the air flow sensor at the top of the airbox and spray some silicone to drive out moisture after you blow it out with compressed air. Frankly , This whining is getting old . I get this from my kids.
Yeah I didn't want to come off whining but it's what it is. Just not what you expect the bike to be in this day in age with EFI engines. We all admire the heritage and craftsmanship of Norton but when you first get on it's not very confidence building. Like I said, I am going to give benefit of doubt to let it break in and dialed in with high flow pipes and remap. Keep y'all posted.
 
Joined
Sep 28, 2015
Messages
131
HI Norton Dallas,


Drop me a PM and I can help you link up with a dealer and get on top of your running issues.

Kind Regards
 
Joined
Jan 5, 2014
Messages
2,491
Country flag
Not many folks on this forum didn't complain about that "bucket of bolts" sound in the beginning. It's nerve wracking. It goes away. New pipes, new remap, break in properly. They sound awesome.
 

Top