HEAD TEMP. SENSOR -- ISSUE

Joined
Feb 24, 2014
Messages
1,759
Country flag
Just a POSSIBLE ISSUE to look out for. The sensor in the cylinder head should not wiggle at all. BE VERY GENTLE NOT TO BREAK THIS!!! This is what a loose one looks like. This usually happens during assembly (not just in Nortons, in all vehicles when someone does not realize they broke it during install and could cause all sorts of problems with rough running. Sorry the poor video quality, it was taken with an iPhone.

HEAD TEMP SENSOR VIDEO







.
 
Joined
Jan 16, 2015
Messages
3,373
Country flag
Hello Richard-7 , The video was fine. So this one is broken ? It looks like the plastic body came loose from the brass fixture . The brass fixing is still tight ? Could this happen from vibration as well ? Just wondering with my frequent trips to 6000 + land.
 
Joined
Feb 24, 2014
Messages
1,759
Country flag
What ever the case, it should not be loose. That is my bike, 440miles. Never even been washed. It runs okay, but when hot acts a little funny. There recently was an issue with one of these for someone else and I had similar issues so I was asked to check mine and when I checked mine it was loose so a new one is on the way. Just thought I'd share.
PS -- YES the fitting is tight, it's the plastic body that is loose and should not be loose.
 
Joined
Jan 5, 2014
Messages
2,518
Country flag
Is it still cold up by you? When are you going to get some mileage on that beast? My Sport seems to like running hot. I'm up to 1700 on the clock and she runs a little better everyday. Thanks for the tip. I'm going to check my sensor right now.
 
Top